How to remove thousand separator when copy/paste in LibreOffice?


using LibreOffice Calc on Windows XP.

  1. Open Notepad and type in number: 1.000
  2. Mark whole number and copy it.
  3. Paste the content into Calc cell A1. Number is copied successfully. Target number in Calc becomes number.
  4. Repeat steps from 1 to 3 by instead in step one type in number: 1.000.000 and in step 2 paste into cell A2.

Number in A2 cell is pasted with dots! (thousand and million separators) and so becoming a text in Calc instead of number. To make me possible to execute some calculations in Calc like e.g. formula in B1=A1+1 I need to manually remove dots from cell A1.

How to make it possible to recognize thousand, millions etc separator as separator and paste it as number?

P.S. I am using Slovenian language settings where dot “.” is thousand separator and comma “,” is decimal separator. So million (with two decimal points) is written as: 1.000.000,00

See attached file for sample.numbers.ods

You only need to format the cells with the number.

paste from notepad 1000 or 1000000 and format the cells will display the numbers as 1.000 and 1.000.000 (I assumed the “.” as 1000-separator)

To format cells, select a single cell or a range, right click, format cells, numbers-tab, number and select the format you need.

The formats available should match your Slovenian country settings.

I understand, if I remove dots before pasting the formatting is OK. But I don’t want to remove dots, this is time consuming - so coping from my web application to notepad then Find-Replace the dots and then paste into Calc. Too time consuming…

This extension could help you, if you do such things often ct2n

I think it is a bug. I haven’t yet tried this extension, I am busy…

With the below settings is right for me. Spanish separators in numbers are the same as in Slovenian.

Do a try with Menu/Paste special/Unformatted text.

Be sure the cells are not formatted as text @ before paste, this make to paste all as text, change after paste do not change the cell content.

Created new Calc profile and opened new text document. Tried to paste with action: Edit/Paste special/Unformatted text - problem remains.

I have done additional tests and it looks to me this problem is a bug, so I have reported a bug:

Current status of fdo#60403 - FORMATTING: Number 1.000.000 paste in Calc like it is a text is UNCONFIRMED.

Resolving Question as BUG FILED.

@froz Seeing answers and comments of 7-Feb I feel we have a bug here. Please file a bug report.