How to set background color in Writer?

What I need is to export the document as PDF and when someone open this PDF file he should see the background of the whole page as one color other than the white color. - that should be included in the question, making it clear that this is not a matter of appearance (what we see when we write), but a matter of formatting(what is saved as PDF).

Background color including margins

Styles and Formatting (F11) → Page Styles (4th icon from left)

Select "Default" → right click: "Modify..." or "New..."

Sample: New… → Page Style: Background

Page tab → Margins

Set all margins to zero

Background tab

Select the background color

Borders tab

Line arrangement: Set all four borders

Line → Color: (e.g.:slight_smile: the same as the background color

Spacing to contents: (e.g.:slight_smile: 20 mm

:ballot_box_with_check: Synchronize

The result

EDIT 2012-10-25


Page Style Background.pdf

Hybrid PDF with embedded "Page Style Background.odt" (open with LibreOffice Writer, save as .odt)

That’s a workaround due to → Bug 33041 - Allow page background to cover the whole page, not only within page borders; see also → OOo Bug 9370 - Off-margin page background (2002-11-19).

Another workaround with a frame → Full A4 background image in Writer

fdo#33041 current status is NEW.

Beware that as of LibreOffice the Background color should now be changed in the Area tab.

As an addition to the previous instructions of changing the document background colors using the Appearance editor, the selection of colors are only limited to a pre-defined list of colors. You can add your own custom color using Menu Tools → Options → LibreOffice → Colors.

Click “Add” to add a new color and provide a unique name, then click “Edit” to set the color to your liking, then click on “Modify” to save this color to the palette. Once this is done, your new color will be available in any of the color pick lists in the “Appearance” section.

This is a good candidate for a separate question “How do I add cutom colors to the palette?” :slight_smile:

Looking at a comment under the question it seems that the question is badly written, very different from what the title says. What the OP wants is not the appearance (color of what we see), but the formatting (what is saved as pdf)

I think he’s asking what I was curious about as well: how to set the actual background color of the Libre Office Application as a whole. If you’re looking at a page in Writer the default page background color is automatic/white, and the background of Writer is a 10% gray or so.

How would you change that 10% gray to be, say…40% gray?

Took a bit of Googling, but here’s the answer:

Go to Tools/Options/Libre Office/Appearance and change the “Application Background” option (third down on mine) to whatever color you want. This will change the application’s workspace background color only, not the menu background colors.

If you mean the "Appearance" (user interface):

Menu Tools → Options → LibreOffice → Appearance → Custom colors → General → Document background.

This did not work for me, ie. it did not change colour.

interesting way to do what Narin asked.
As long as it is only a change in color on screen, it works as proofen above. But if Narin considers to print the entire page (= paper) with a certain background color, I am afraid it will not work. Reason: Every printer has a printing area limit wich is a bit smaller than the paper.

I am now curious what Narin really wants to do.

Thanks everyone.

What I need is to export the document as PDF and when someone open this PDF file he should see the background of the whole page as one color other than the white color.

See my comments above (or below). :wink:

Could you move this additional info to the original question?

Too bad I can’t upvote to say thanks just because I’m new. This is an atrocious policy and counts as a major down side to recommending libreoffice to clients/friends etc.

“Yea, it’s a nice app suite I guess but you can’t trim down the portable version to just writer and the forum assumes you’re a spammer or something and cripples your ability to interact out of the gate.”


ThornyJohn, thank you :slight_smile: I’m sorry I can’t upvote your solution. :confused:

Sidenote to whom it may concern: Posts like the one I’m now writing are like roaches, for every one you see there are 10 you didn’t.

It’s been a while since you posted this, and some things may have changed in the way this site works. Before you can vote, you need one upvoted question or answer. It’s too bad people don’t seem to be voting much, but comments like this do not particularly help to get karma :expressionless:

This answer does not really answer the question, so in my humble opinion it should have been a comment under the answer you’re referring too.

Thanks for contributing, though!

Has this issue ever been addressed? I really want to be able to work with the whole page in a brown background, and white text in the middle. I have bad eyesight. I need the margins, so Web Mode won’t work for me, and white margins with brown background are very distracting. I will have to go to a commercial product if this isn’t addressed. It seems like a very bizarre bug to just let happen. I wish I was a coder so I could help fix it.