How to set default calc sheet formatting for all new sheets

I’m trying to figure out how to set the default style for cells in a new sheet in calc. I created my own template and formatted the cells with the font and padding I want and when I create a new document it properly uses my template and my initial sheet has my custom format.

However, when I add a new sheet all of its formatting is back to the original calc default formatting. My template font and cell padding are gone. I can work around this by doing things like copying the initial sheet or inserting a sheet from the template manually, but all of that is extra work that defeats the whole point of having a template for me. It seems like there should be a way somehow to define what a new sheet’s default format should be every time it is added. I thought that’s what a template was for, but I must have set something up wrong.

I can figure out work arounds, but I’m asking if there is a native way to make calc use a sheet with my custom format, not only as the initial sheet, but as the default for all new sheets inserted. Do I need to create a sheet template or style of some kind as well?
MBDefault.ots (6.9 KB)

Please edit your post and …


…attach the initial Template-file without confidential data.

I have updated the original question, with an upload of the template I’m using.

I assume that you have selected all the cells in the sheet and formatted them.
The correct way is to change the Cell style Default. Open your template file, Menu / Styles / Manage Styles, right click on Default style, Modify… Then save your template file as default.

Thank you, yes, you are correct, that is exactly what I did. Following your instruction I was able to successfully get my new sheets to now have the correct custom cell format by default.
However, even though the cell format settings are properly set, the initial row height of the new sheet doesn’t honor the actual size of the cell format font size and padding, it still the original native default row height. I can correct it by selecting the sheet and then manually selecting optimal-height adjustment. Is there an additional style I can set to have the row height of the new sheet honor the actual size without manually setting optimal-height?

Attach a blank sheet template to your document template and copy that whenever you need a new sheet.
Or use menu:Sheet>Insert Sheet From file … where the file contains the template sheet(s) you need.

Thanks Villeroy for the suggestion, that’s what I’ve been doing as a work around. The basis of my posting was to try and learn Libre Calc’s intended workflow to handle custom templating and formatting using the intended built in tools. Sokol92’s answer is the right direction and I think what Libre calc is expecting a user to do to achieve the result I’m after.
Perhaps there is no way to set the row height default and then the best functional method for getting a custom, fully formatted new sheet is a choice to either continue using a dummy sheet that is copied for every new sheet or setting the cell default style, but then having to take an extra step to click set optimal row height on the new sheet.

There is no such thing as an intended work flow. A spreadsheet is a freehand tool.

Since 99% of all users try to use it as a database surrogate, there is only one thing: Never split equally structured data across multiple tables. Do NOT create separate invoice sheets for each client. Do Never enter your stuff on separated sheets for Jan2022, Feb2022 etc. And do not store your data in contigency tables (aka cross-tables). All the features related to pseudo-databases (lists on sheets) relate to normalized tables.

1 Like

In addition to @Villeroy , to achieve understanding:

Database General

Maybe you have not eliminated all direct format in the sheet, A1 has ‘Calibri’ as font and ‘Default Style’ has ‘Liberation Sans’

Try Menu/Edit/Select All and then Menu/Format/Clear Direct formatting, so only ‘Default Style’ is applied.

mariosv, the template attached to the original post is not the one where I have modified the default style per sokol92’s reply, that’s why it still has the wrong default format font. Here is the updated one with the custom default.
MBDefault.ots (7.7 KB)

Hello! The default row height is determined by the parameters of the Default style.
Add a sheet, select all cells (Ctrl+A), right-click on any row number, select Optimal Height and press Enter. All rows must have the desired height.
Looks like we’re dealing with a bug. You can report it to Bugzilla: .
As a workaround, you can make several (hidden) sheets in the template and then (open) delete the extra ones.

Thanks for the help everyone, I submitted a bug report and marked updating default style as the solution.