How to set LO as default for docs created in LO

I have had LO as the office program on my Windows 10 (HP Pavilion) laptop wince I first got it in July 2016. At first, everything worked fine, then there appeared the 'open with" button, which I learned to use and which worked just fine until a few days ago. There has been some automatic system updating going on on the computer within the past week, and now I can’t open any of my LO writer or calc files. The program will not open from the taskbar, nor the apps listing.
I think windows is trying to force Microsoft Office on me, but I refuse to pay all that money. I have tried choosing
'find another app" and setting LO as default , but none of this seems to work.

A similar question was asked here