How to set PDF view in max width?

How can I set PDF files to open in max width? There seems to be no settings in LibreOffice to do this and it is annoying to have to adjust the view each time you open a new PDF file.

I am using version with Windows 10. If you are running 7.0, then I’m not there yet. 7.0 is in beta right?


No, this works for the current PDF file you want to view. I want to PERMANENTLY change it so that ALL PDFs open in max width. How do you do that? Thanks.

It works here, with Setting it once when exporting a PDF, makes it stick for all following exports, since the dialog saves the PDF filter settings in user profile.

If it doesn’t work, then mention your version, your OS, and provide a document that opens in LO, and on export does not follow the previously-set option.

@mikekaganski, it seem that both of us misunderstood the question, because OP says to open PDF in Draw. Deleting my “no answer”.

@LeroyG: I believe we got the question right initially: OP wants to save the opened PDFs with max width. Why do I think so? Because to your answer with specific directions, OP has answered that “this works for the current PDF file”. So either OP hadn’t read your former answer carefully (and so didn’t notice wrong setting advised) - and doing so, created a confusion; or your idea was right, and there’s something (profile corruption?) preventing your correct answer from working on OP’s system.

@mikekaganski, Don’t understand why OP wrote “this works for the current PDF file” because it doesn’t even work for the next time you open it in Draw. By default, Draw override zoom preferences saved with the PDF and ever open in “Entire page” zoom mode.

So, to me, the question is: Is there a way to change default zoom from “Entire page” to “Fit width”?

1 Like

Yes, that’s it. I want all PDF files to open max width. Is there a way to set that?

As a workaround, if you want to easily view pdfs at page width, you could assign a keyboard shortcut in Tools > Customise > Keyboard. Note that recently the Modify button was renamed to Assign.

It seems no this setting inside the app, you can have a try with other pdf viewer, such as Okular. pctechtest