How to setup default decimal value for currency?

Hi everyone,

In Libreoffice calc, When i’m using currency format, my currency (VND) always had 2 digits decimal, While my currency didn’t use it (VND) anymore. So each time i’m using (Ctrl+Shift+4) to format my currency, i need to remove that decimal.

are there any ways to make it default ?

P/s : I have changed windows 10 language setting, included currency and number format to match VND currency format.

Sorry for my bad english.



This problem has been fixed :

Which currency in what country is that? The default currency format is taken from locale data, if that says the currency has 2 decimals then that is used in currency formats. Maybe the locale data is outdated or faulty.

My Locale is vietnam, and i have changed the locale setting in my windows 10, included number and currency format to match decimal of VND. But in Libreoffice, i can’t understand that why it’s still use decimal?

LibreOffice for its cross-platform nature comes with its own locale data, in which the vi-VN locale for VND (added in 2005) has 2 decimal places. That is congruent with Vietnamese đồng - Wikipedia that lists 1/10 hào and 1/100 xu, but also says “both subunits have been unused in Vietnam for several years”.

The vi-VN locale data needs an update for the next release.

I created tdf#131829 for this.