How to specify which browser opens on clicking a link?

Suddenly, for no apparent reason, links open in Chromium instead of Firefox. My system setting (Linux Mint) is set to Firefox. No other program opens links in Chromium. I can find nowhere to tell Libreoffice which browser to use.

Maybe this is more appropriate question for Linux Mint forum, because as I know there is no settings in LibreOffice which browser opens web links…

Valid point, except ONLY Libreoffice is doing this. But I’ll give it a look.

I think this Linux Mint forum thread will help. It sounds like your Chromium settings may have gone awry.

Thank you! It was the WORST sort of problem. The “Petty Annoyance”.