How to stop hard-returns when pasting hyperlinks

When I try to post an entry in my bibliographies, they often include links to articles. Often, those links include a question mark in the address. Whenever I have such a link, Writer does a hard return after the question mark. How can I make it not do this?

Edit: I am running Fedora Linux 38, LO version, and am saving the files as .odt files. The entries are being copied from the internet via Firefox, using ctrl+c. They are being pasted with ctrl+v. An example: “David J. A. Clines. Job 38-42, Volume 18B. Zondervan Academic, 2017. EBSCOhost,?,url,uid,cookie&db=nlebk&AN=1780527&site=ehost- live&scope=site.” Writer is forcefully starting a new line after “aspx?”, and if I backspace before “direct” it deletes the question mark. How do I make it not do this?
The document is being formatted in MLA, and I have made changes manually to the Default Paragraph Style.

Improve your question by editing it (= modify it, don’t add a comment) to mention OS name, LO version and save format. Give an example of an entry. Where do you get the entry from? How do you copy it? How do you paste it? Generally speaking how do you format your documents? Manually or with styles? (In other words, what do you know about styles?)

That has been done. Thank you for the advice on asking questions.

I was puzzled by word “hard return”.
Assuming the entry is pasted as unformatted text to avoid any HTML formatting from “polluting” the Writer document, Writer does not add any character or formatting mark on its own. In the given example, you have a very long string of characters which can’t be interpreted as a sequence of “words” because there are no spaces. Writer handles “literary” text and tries to layout text nicely, i.e. spread it over several lines (when lines are full). Since there are no spaces, it looks for punctuations because punctuations end sentences are “natural” boundaries. These punctuations are exclamation and question mark, period and comma (with special care as they can be decimal separators), colon and semicolon, dash (as hyphenation potential location).

The line wrap which occurs at end of line is not a real character (nor explicit formatting mark). It is just a split of the long string computed by the layout engine.

Said it otherwise, you can’t do anything. Eventually, if your bibliography is overcrowded with such long sequences, you can format your bibliography in landscape-oriented pages, adding a real paragraph mark before the URL and after it. Of course, give the URL an adequate paragraph style (to be created) so that the URL is not mistaken for an independent bibliography entry.

Writer usually identifies URLs and applies a specific character style Internet Link to them. Behind the scene, the URL text is associated to a live link (you can control-click to launch your browser to navigate to it). The link is stored in a separate area and does not get damaged by linewrap necessities.

PS: you mention changes to Default Paragraph Style. I remind you that this style should never be used to format anything in your document. Its role is to define common settings to all other paragraph styles like preferred font face, size, indents and spacing, … What you set there is shared by the other styles (unless a parameter is overridden) and this contributes to give distinctive look to your document. Changing parameters may result in surprising effects (from your point of view).
The “standard” paragraph style for text is Text Body. But this style is for the “discourse”. Bibliography entries are specialised text. Consequently, a dedicated style should be applied, like built-in Bibliography 1.