How to stop text dropping two lines when using enter

If I use enter the text drops two lines when I only want to go down one line. How can I change this to one line? It is already on one line spacing

Pressing ‘Enter’ you create a new paragraph. There are settings for the paragraph style including the spacing with respect to the paragraphs above and below (and between lines inside the paragraph).

Always keep ‘Formatting Marks’ shown to better see the structure of the document. Decide conciously whether you actuall need a new paragraph (‘Enter’) or a hard line break (‘Shift’ + ‘Enter’). Check the settings under ‘Indents & Spacing’ for the paragraph style you are using.