How to stop writer auto-capitalize "i" before "-"

How can I stop LibreOffice 4.0 Writer from (auto-correct) automatically capitalizing every “i” before “-”? This does not happen for any other letter before the “-”, except for “i”. This looks like a bug or a very poorly considered feature. Thank you in advance, alvin

Oops, I think I found the solution indirectly from Somethings aren't being automatically capitalized - the auto-correct replacement table replaces every “i” standalone, including “i-” apparently to capitalized I.

You may use additionally:

AutoCorrect → Replace

Replace i# With: i

Type: i#-

Replaced with: i-

Type: i# -

Replaced with: i -

Type: i#.

Replaced with: i.

There is a way without having to modify any auto-correct option. Whenever an unwanted auto-correction occurs, you can simply undo (Ctrl+Z) by one step. This applies to any auto-correct situation.