How to unhide all text in a document

I often have sections of hidden text in a document (via Font Effects or MS Word shift-ctrl-h) that I need to unhide.

I’d like to be able to click ctrl-f10, mark everything using ctrl-a and remove the hidden flag via Font Effects (or via key combo but that’s not really the problem) as I can in MS Word.

LO Writer does not allow me to change the corresponding checkmark in Font Effects unless all the text under it is either hidden or unhidden. I haven’t found a way of doing a search and replace using formatting as “hidden” is the only option in Font Effects that Search/Replace doesn’t include.

So I have to go through each section individually and manually unhide it. Which seems to be an awful lot of unnecessary work.

At the moment I have to start up a Windows VM, start Word, and open the document just to be able to unhide all the hidden text sections.

IIRC this was not a problem on previous versions of LO writer.

Am I missing something?

ETA: Yes I know I can select “Clear direct formatting” but that destroys all formatting, not just the hidden flag, so that’s not really an option.

Since you are aware of dangers of direct formatting, you should think about using styles, both paragraph and character styles. Then you could hide/unhide simply changing one or two styles.

Also, depending on what you want to hide (full paragraphs, entire (sub)chapters or sections), you could have a try with conditional formatting. Display of marked sequences can then be controlled from value of a variable.

IIRC this was not a problem on previous versions of LO writer

Please file a bug report, and attach a sample file.

Thanks for the comments. Unfortunately, I’m very limited as to what I can and can’t do to a text as I process client files that are sent to me, and have to send them back with only the alterations that are actually required by the client. That includes applying styles. I hide and unhide text so I know what to work on and for billing purposes. Added to question.

In this case, rather than hiding/unhiding text, think of highlighting the to-be-worked on sequences when you receive the document. When you edit, you progressively remove highlighting on the completed sequences.

Without a concrete example of your workflow, this is my best suggestion.

Thank you for your suggestion. I can’t go into my workflow, sorry. Please trust me that I have looked into possible workarounds and they are too time-consuming, unreliable or would otherwise double my workflow. Since I’m working with other people’s documents that may already use highlighting (or other forms of formatting, field and style definitions and whatever) for their internal purposes, using the hidden/unhidden feature is pretty much the only structural alteration to the document that I can safely make. Even so, many thanks for your suggestions!

I’ve now checked this using LO on a Raspberry Pi and on a Windows VM, the bug does not appear there, so it’s definitely a bug, not a restriction to the feature or similar.

FWIW I have already submitted a bug report.

Menu Tools▸Options▸Writer▸Formatting Aids▸ and check the box for “Hidden Characters”

That allows you to view hidden text, assuming you have toggled “Formatting Marks” (Ctrl-F10). (Hidden text will appear to have dotted underlining.)

Next, if you want to UN-hide the text, simply select all the paragraphs or words that are hidden (as indicated by the dotted "underlining and select Format / Character / and uncheck “Hidden”

On the other hand, if you simply wish to move back and forth from either seeing or not seeing the hidden text, just go back to the first instruction at the top of this message and check or uncheck “Hidden Characters” in the Tools / Options… menu. My suggestion is that you leave this option CHECKED while you are working on client files, UNCHECK before you send back to the client.

IMHO this is not what OP expects.