How to write text and TexMaths equations together in Impress

I use the TexMaths tool to type equations in Writer and Impress, because TexMaths supports Latex. In Writer, it is easy to type a line like the following:
“The equation is a+b=c”
where I type “a+b=c” in TexMaths and then it will be embeded in the text.
However, in the Impress, this seems impossible. First, I use the Text tool to type in "The equation is ". Then I click the TexMaths Equations tool and want to type “a+b=c”. The system says “The selected object is not a TexMaths equation…
Please unselect it and call the macro again…”
I need the text and the equation be in the same line just like the case in Writer. Does anyone know how to do this in Impress?

That is not possible, because the text objects of Impress are not able to contain OLE objects inside them, neither the presentation objects nor the text box. You will not be able to put a Math-Object into a text box too. If I need text together with equations, I have two techniques: (1) I write the text inside the equation. (2) I write the text in the text box, write the equation as new Math object, and then group them so that I can move them together.

Well, as @Regina mentioned this is an issue that has yet not been solved.

Nevertheless I found that installing the old OOoLatex extension that was available for OpenOffice, does the job.

In principle just follow the instructions on this ArchLinux wiki:

Download the extension from here: And also the fonts linked there:

Install the extension by downloading it to your disk and opening the Extension Manager in Libre Office → Tools.

Then also install the fonts, as mentioned in the wiki, in order to have available simple mathematical expressions in line with the text using the Expand option of the OOoLatex extension.

Restart LibreOffice and you are ready to go.

This worked for me on a manjaro Linux, but these steps are completely distribution-independent

It works! Even in Libreoffice 4.4! The only complain is equations look ugly when using OooLatex Equation - png. Is there a way to fix that? (I´m on Ubuntu 14.10)