How/where do I lock/unlock a file?

We had a minor disaster - PC crashed. All data moved to new disks on new PC. So far, so good. Unfortunately, all Libra files are locked and we can’t unlock them. I cannot fund any reference to ‘lock’ or ‘unlock’ in the help.


Libra V English. Files moved from Windows 7 from Windows XP

I think your problem is caused by hidden temporary files locking your document

When you open a document, a hidden temporary file is created in the same folder. It will be named similar to the document. For example, when you open ‘myfile.ods’, a temporary file named ‘.~lockmyfile.ods#’ will be created.

Usually, they are removed when LibreOffice closes but if it closes unexpectedly, the temporary file may persist and prevent you from opening the document.

To view hidden files: I assume you have moved TO Windows 7 from XP.
Open a Windows Explorer by holding down the windows key and pressing ‘e’ (WIN + E), or Start - All Programs - Accessories - Windows Explorer.
Organise → Folder and Search Options.
View Tab: select ‘Show hidden files, folders, and drives’.

You should now be able to see any hidden LibreOffice temporary files in the same folder as your documents. Delete them and your documents should open.

I hope this helps. If not, please provide more details. For example, the exact wording of any error messages you may be receiving.

I have this same issue, from an unexpected crash of libreoffice on my mac. Libreoffice will not allow me to recover the file I Writer document I was working on - I can see it as a file that can be rescued but the rescue fails. The file is now also missing from my documents folder and recent documents in Libreoffice.

From reading this thread after trying to work the problem out, I found the hidden locked files in my documents folder, deleted them, but still no go. I’d really like to find the file if possible - I was writing a research paper for work and had a good couple of days on it (hate myself for not backing it up when I had the chance!).

I can start another thread if needed, but this seems to be exactly the problem I am having (just on mac), and it seems the thread was never marked solved so I thought here would be a good place to keep any relevant information.

All suggestions and comments really, really appreciated. Thank you.