HowTo use a remote server with SSH

I’m trying to connect to a local linux server on the same internal subnet as my pc. The server is at and my pc is at The linux server has port 21 FTP disabled (as is recommended for security) but has the SFTP port 22 open (and I can connect via WinSCP so I know it works).

In LibreOffice when I try to open or save a remote file, a Remote Files dialog box pops up and I click on Add service. A new box opens and I select Type = SSH, enter as hostname and leave port as 22, then enter the same user/password that works in WinSCP. For root I’ve tried (empty), /, and an explicit path like /home/myuser (but nothing seems to work) and click OK. The dialog box closes but nothing happens even after several minutes.

So one of three things is going on: I’m entering something invalid (like perhaps it should be in which case there is NO DOCUMENTATION in the HELP!, the feature is broken, or something else needs to be setup - again there is NO DOCUMENTATION in the HELP! Googling something like “libreoffice remote server” brings up stuff that is useless as it refers to other scenarios like GoogleDrive.

So my question is how do I make it work? and my comment is Why isn’t there any documentation?

(In fact - there is very little useful documentation in the Help - people are changing features monthly and not bothering to document anything. What little I can find is often obsolete - screens show options that don’t exist, etc. How can I possibly deploy LibreOffice to ordinary people who are used to tools like Microsoft Office that have lots of useful documentation?)


I reproduce the problem (windows 7/64 & I found this bug report: tdf#98897