hsqldb v2.3.4

I am going to create a split database and was planning to use hsqldb v2.3.4. I did setup my libreoffice but when I create new database and then try to reopen the database I get the error that database connection can not be created and that the database was made using the newer version of the libreoffice?
I have libreoffice 5.2.3 on a windows 10 machine, and I have tried on ubuntu with the same results.

It is not quite clear what procedure got you to the current state. It appears you have opened an embedded database with an HSQL other than v1.8 (which is included with LO). The v2.3.4 should only be used in the split folder and not set in LO. If you have added this to you class path, remove it. It can corrupt other embedded DB’s.

The correct process for creating a split database is on this post - click here.

This problem can also occur if opening an LO embedded DB with OpenOffice containing a newer HSQL.

That might be the problem because I am replacing bundled v1.8 with v2.3.4. I have not tried it with split data just with the embedded database.
My question remains that if I replace hsqldb and try to create a new database in embededed format, after closing that newly created database and reopening it, I get the error? Which I dont understand as database was created with same LO and HSQLDB.

The properties file of the database is different for v1.8 vs v2.x so when you create the initial DB, all seems OK because LO doesn’t perform a check on the properties file - it’s new. When you re-open it, LO checks this to insure it’s for v1.8 and doesn’t pay attention to your change of the HSQL. Since it is not as expected, you get the error. Firebird is being worked on for the embedded DB but has a way to go. Best bet is split or external such as MySQL or PostgreSQL.