Huge gap in text (LibreOffice Writer)


I simply cannot find a way to get rid of the gap (see attached picture) - “the” and “mystical” need to be merged, but that gap is preventing it. Please be so kind and explain to me in layman’s language how I can solve this problem.

LibreOffice version: - 64 Bit
OS: Windows 10
Document Type: ODF & Word 2007-365

Thanks in advance.

Please specify to all inquiries:

operating system
LibreOffice version (four-digit, e.g.
file type in which saved your file


And upload a sample file showing the problem here. Thank you.

While waiting for the sample file which will show which formatting you applied and how (styles vs. direct formatting), my wild guess would be you have a weird combination of settings about widow/orphan + grouping paragraphs together. But even this guess does not explain the size of the gap. Another possibility coould be the size of note 319 again with weird formatting configuration in this note.

Hi, it is a more than 300 pages long document with more than 1000 footnotes, but there should still be a way to negate that gap somehow.

It is certainly possible to cope with this gap but we need to have some idea about how you configured your document. Since the mishap is local, make a copy of the document and erase everything preceding page 64, keep at most 5 pages and erase everything after that. Make sure the problem persists and attach this reduced version of your document.

I seem to be able to reproduce the issue but I absolutely need to check your context.

The problem disappears when I cut down the pages. But when I try to copy and paste the “repaired” text into the original document, the problem recurs. Sending you 5-6 pages won’t reproduce the issue.

Please help me resolve this issue; this is a disseration that has to be sent to the publisher very soon.

That blank area is dead or locked. I can’t do anything with it.

I hope you understand what styles are.
What is the page style applied to the problematic area? Open it and go to the Footnote tab. How is the Footnote Area configured?

Has your document ever been edited by Word? Before you saved it as .odt, was it a .doc(x)?

1 Like

I could make a screenshot of the relevant setting; please tell me where I should go.

And yes, this was originally a Word Document, but I switched to Libre halfway through my dissertation.

Select the Footnote tab, on the far right. There’s an option for a maximum height of the footnote area. You will need to make that a bit larger to allow for the extra footnotes that come with those lines.

As you can see, I already I have pages where footnotes occupy 50% of the space; hence that is clearly not the issue here.

And there are no further footnotes on the page with the blank area.

Please display a screenshot of the Footnote tab. Contrary to what you think, the footnote area height is the issue. I need to know your setting to give you advice.

The problem arises when you have several (many?) note anchors close together. The default algorithm to allocate footnote bottom-of-page space gets confused and causes this gap. The algorithm tries to keep both the anchor and the note on the same page. What you show in your 50% footnote occupancy screenshot is typical of what causes confusion. Show your settings.

And the confusion is even aroused if you direct format your document instead of styling it. If your document has ever been .doc(x) or imported from Word, its structure is already damaged.

Is this what you need?

Activate Maximum footnote height and set the height manually. A value between 50% and 75% of the usable height in the page should do. If the problem still persists on some pages, reduce the height.

This may seem paradoxical but this is what I ended up with from experience. Considering the considerable amount of notes in your document, you’ll have to find the optimum to avoid flushing note text in pages too far away from the anchor.

Is this the only function I need to adjust or something else in addition?

Have a try. Since I have no access to your document, I am not sure 100%. If it does not work, report here.

After testing a bit, it seems to me (I could be wrong) that the note anchor must be in the same page where the note starts.
If the size of note 319 don’t allow for the note 320 to start in page 64, since both anchors are in the same line, Writer would force this line to next page.

As a workaround, you can disable the paragraph (style) widow control, cut the 319 anchor, and paste it after Schopenhauer, or after tool.

See a simple file to test: footnotes to test LeroyG.odt (24.0 KB)
LibreOffice, on Linux 5.14.


1 Like

Many thanks, I will try out these suggestions tomorrow. It’s getting late here and I’ve been up for 20 straight hours.

Unfortunately the implementation of your suggestion aggravated the problem: the gap was gone, but the footnote was no longer shown on the correct page but several pages later.

I am sorry, but I don’t understand the instructions.

How large is your document? You can send it either attached to an AskLO private mail (but I’m afraid you’re limited the same as with question) or through a direct mail to me (limit ~ 5MB).

For an LO private mail, click on the icon next to my name and press Message.