Hyperlink in spreadsheet works in Excel fails in Libreoffice

I have a hyperlink which in Excel appears as follows: file://localhost/volume/my documents/testfile.txt - this works in Excel
The same hyperlink in Libreoffice appears as follows: file:///volume/my documents/testfile.txt - this fails in libreoffice.
I have tried saving the file as .xlsx, .ods, problem still exists.
This link is referencing a SAN disk on my network.
Hyperlinks to the local hard drive work in Excel and Libreoffice. e.g. /Users/my documents/testfile.txt. work in both Excel and LibreOffice
I know that in libreoffice I need to use cmd+click to select the hyperlink, whilst in Excel you can just click.
I am using an Apple Mac Pro, Mac Os Mojave, 10.14.5. LibreOffice, Excel for Mac 2011 14.7.7
I would like to use LibreOffice instead of Excel but this issue is a deal-breaker and if a solution doesn’t exist then I will unfortunately have to revert back to Excel.

Have you tried re-creating the link in Calc using menu Insert → Hyperlink??

Hi, Yes I have but the problem still persists. It appears that LibreOffice only allows for hyperlinks to documents located on a local disk, not to documents located on a network device.

Sure sounds like a bug. If it can be verified, please report it at Bugzilla

Maybe someone else here can suggest a suitable workaround that you can use until the bug is fixed.

This is tdf#91851.

On the other hand: what is the actual use case in using localhost URLs? they can’t be used for creation of files accessible from network (since that would require to use specific host name), so why not use the universally accessible (from LAN) SAN URL instead of its mapping to local system’s share? (This, of course, is not meant to say the observed problem isn’t a bug - it surely is.)

Hi Mike, that’s what I thought. The original string is :volume/my documents/testfile.txt The file://localhost/ I is assume is added by Excel. Either way I cannot get any of the differing permutations mentioned to work, very frustrating.

I cannot get any of the differing permutations mentioned to work

I don’t know what you mean… The bug in its current state doesn’t allow using localhost (or; you may try using though - it isn’t handled specially in our code. So try

file:// documents/testfile.txt

Hi Mike, perhaps we could ignore the localhost issue. My original question was why /Users/my documents/testfile.txt works in LibreOffice but /Volume/my documents/testfile.txt does not work in LibreOffice. Thanks for taking an interest in this issue, greatly appreciated.

Exactly because of the localhost issue. So no, we cannot ignore the localhost issue.

file:///volume/my documents/testfile.txt is a bad URL for Windows: Windows doesn’t have a root (unlike Unix-like systems), so nothing like path /volume/my documents/testfile.txt (starting from the forward-slash). Initially, the URL looks correct: file://localhost/volume/my documents/testfile.txt - which should convert to UNC path \\localhost\volume\my documents/testfile.txt, which refers to a network share attached to your box, but since the localhost part gets stripped away, it ends up in that invalid thing.

On the other hand, file:///c:/volume/my documents/testfile.txt gives correct path, and isn’t affected by the bug.