hyperlink to target sheet in current doc stopped working in

Web links still work.
Links to open other documents still work overall, but will not open to specified target sheet.
Links to ‘target’ sheets in current Calc document do not work.
I tried deleting link and recreating, no luck.
I tried turning off and back on the ‘ctrl’ click option under security, no luck.
I tried creating new links to different sheets in current doc with no luck.

When I click on the link, I get the ‘wait’ circle for a short time, but nothing happens

I just tried this in LO on Ubuntu 18.04 LTS, which OS are you using? As shown in the image, out of the box with default settings you need to press the CTR key and left click the hyperlink to follow it,

I’m using Windows 10. I have the ‘ctrl’ option turned off. Clicking on links works, but not to ‘target’ sheets in a new spreadsheet. It will open up a web link or another spreadsheet, but not to the target sheet, and not a different sheet in the same spreadsheet.

I have the same issue with Calc. Hyperlink opens the document, but it does not go to the specified page number in that document (.pdf). Windows 10, LibreOffice version =
When will this be fixed?