I can not open my spreadsheet it comes up with this error: Read-Error. Format error discovered in the file in sub-document content.xml at 2,72157(row,col)

How can i open up the spreadsheet with this error: Read-Error.
Format error discovered in the file in sub-document content.xml at 2,72157(row,col).

the calc spreadsheet is where my file is.

For some reason, I have a gold badge, but no karma, so I can’t upvote. Great question!

The file is corrupt. Make a copy and work on the copy. Change the file name extension to zip and open the container. You will see the file content.xml. Open the file in an editor and go to the place mentioned in the error message. If you are lucky you will detect the error, for example a duplicate attribute. Repair it and save the corrected content.xml to the old place. Leave the container and change the file name extension back to ods.

If you do not detect the error, you can try to open the file content.xml in another application, for example in a browser and perhaps get a more detailed error message.

If you are still without success, I fear, repairing is not possible. Do you have enabled to generate a backup? Then goto your LO user directory and look at the backup folder. Hopefully you find a version not too old.

You might be able to extract the cell contents from the file content.xml. It is not a binary file, but human readable. But that is very tedious.

Fantastic answer! Detailed, and it worked for fixing my problem, which had the same error message as LGC. Thanks much!

Thanks for this answer.

Could someone explain that simpler and take me through step by step??

“Open the file in an editor” should be “Open the file in a (plain) text editor”?

Perfect. Worked fine. These are the steps I used:

  • Select the .ods file, and extract the contents using 7zip
  • Edit content.xml with Notepad++
  • Move cursor to the location that the error message complains about.
  • removed the duplicate attribute, in my case, fo:font-style="italic". Save & Close file
  • create a new zip archive with the contents of the extracted files. Archive should not contain *.bak file created by notepad++, and no root folders.
  • Rename *.zip to *.ods.
  • Works!

This method worked, but needs one additional note:
From WinXP, after renaming the file as .zip, manipulate content.xml directly from the WinExplorer:

  1. Click on the .zip file name to open a directory style view of the archive contents.
  2. Copy content.xml, past into another directory, repair that copy
  3. Paste the repaired copy into the ,zip file using the WinExplorer view
    Manipulating the .zip file by e.g 7-Zip results in a file that LibreOffice finds erroneous.

To add to @Regina 's great answer, the error I found in the content.xml file wasn’t in the mentioned cell number. It was enough to extract the content.xml file and open it in a browser to see that some styling attribute at the beginning of the document was for some reason duplicated. Removing the duplication and putting back the content.xml file in the ods file using a zip utility fixed the problem.
It is worth mentioning that updating the content.xml to the ods file wasn’t successful in Mac OS X. The archiving tool did not produce a valid ods file after zipping the directory content. I had to switch to Linux and took a couple of minutes to solve the problem. Maybe a tool on windows works fine as well.


I have the same problem, but in addition my problem is that I don’t see the content.xml file. I zipped the file, but it doesn’t look right. I would really appreciate your help and thank you in advance!

Thanks from the desperate :slight_smile:


You have to unzip the file. Work on a copy and change the filename extension to zip. Then try to open/extract/unzip or whatever your packer calls it. Is that possible? Please tell us your operating system and the LibreOffce version (or other application) which was used to generate the file. When you open the file in a simple text editor, does it starts with PK?

Hi, thanks for your answer!

I have made a copy, I have zipped the file, but when I unzip it, I can see the file extension is still .ods.

My operating system is Windows 8.1 64 bit.

And I use LibreOffice Version:

Yes, it starts with PK!


Hi Anna, you wrote “I have zipped the file”. That step is wrong. Simple change .ods to .zip and then unzip it.

Thanks… I had problems with that, but now I know, where to look. I have, though, solved the problem. I opened the file through Google docs - I was lucky it worked - and then I have saved it as .ods.

I know I am not a technical genius, but thanks for your help and time. Two months of work is saved and a backup created :slight_smile:

Have a nice day,


Hi, applying these steps don’t work for me. Is there a person who can fix this error for me?

I got my liberOfficeCal.ods file currept while i try to open. it throw error message “Read-Error.Format error discovered in the file in sub-document content.xml at 2,94039(row,col).” I tried to open this file in different Liberoffice version… i saw their is already Bug raised in Liber Office…So i understoood that their is problem with Liberoffice Cal…

Recover File…
I spend almost 2 hour google to find any alternate software who can recover my file or open online… ohhhhh…Finaly i tried Google Doc Create Documents–> Go to file–>New–>SpreedSheet… it will open new spred sheet now here again go to File–>Open–>Upload the file… It will open ( I hope it works…for you) Now you can save the file as you wish to save in different fomat…

I have the same problem. It reads:
Format error discovered in the file in sub-document content.xml at 2,114358(row,col).

When I try to open content.xml in browser, it said:
XML Parsing Error: mismatched tag. Expected: </text:p>.
Location: file:///home/forevernikn/Translate_Proposal_Making%20All%20Voice%20Count_ALPENSULTRA/content.xml
Line Number 2, Column 114359:<office:document-content xmlns:office=“urn:oasis:names:tc:opendocument:xmlns:office:1.0” xmlns:style=“urn:oasis:names:tc:opendocument:xmlns:style:1.0” xmlns:text="urn:oasis:nam

So, I can’t check the duplication or any error.

I tried to open it using Google drive couple times, always failed to upload, something error. I managed to upload it but it won’t open.

I have tried all answers and steps mention here but still it won’t open. Anything else I can try? I am still using traditional way to translate document until it solved.

Thank you

If the instructions here are not enough to let you repair the file yourself, then you need to provide the file for download. Perhaps someone else has time to try to repair it.