I cannot break a link to a file in Impress

I am using LO version, Build ID: 1:6.4.7-0ubuntu0.20.04.6 in OS: Linux 5.15; UI render: default; VCL: gtk3; Locale: pt-BR (en_US.UTF-8); UI-Language: en-US.

Any image (as far as I know) linked to a Impress presentation will not be embedded into presentation when its link is broken in Edit - Links - Break link.

How to reproduce it:

  1. Create an empty presentation;
  2. Add a linked image;
  3. Save and close;
  4. Open the same presentation again;
  5. Choose menu “Edit”, then “Links to External Files…” ;
  6. In the window that opened select (if not already) the linked image;
  7. Click the button “Break Link”. The linked image will be removed from the list (although the “source file” field will still show it;)
  8. Click the “Close” button to exit the dialog;
  9. Save and close the presentation.

You can then either check its size to see it did not increase (as it would be expected if the image had have been embedded) or open the presentatio again and check the link is still there. A third way to check it is to rename or delete the image file and reopen the presentation: It will show the broken link object.

The attached files can be used to check it. It started happening some years ago (it seems to me it started on the first release of version 6 and it did not happened in version 5.)

Update This bug does not show in Windows LO v5 (last release) and LO v6 (first release), but my Windows is a 7 pre-SP1 so I can’t test anything above it. I was able to test a Flatpak v7 LO (in VanillaOS) and it has not shown the bug either. It might be an Ubuntu 20.04/apt only issue. I’ll try different versions in Ubuntu to confirm or deny it.

Most of the time this is not an issue for me since I work with linked images all the time. But I’ve been needing to send presentations away and it is forcing me to export to PDF to do so (or to send the image folder togheter which is bad anyway because it forces my workflow on everybody else.)

Please, does anybody know a workaround to it or why it happens?

Thanks a lot,

P.S.: Right after posting it here I am testing in other Linux flavors and Windows, both with versions 5, 6 and 7. I’ll post the results.)

ImageEmbededForever.odp (18.6 KB)
ImageEmbededForever-BrokenLinkWorkedNot.odp (18.6 KB)

That looks like the fixed bug 119661 – Embed linked image via menu "links to external files"->"Break link" doesn't work.

You can right-click the image and use item Replace. Select the same image, but now without linking. Then save the file. The image will be embedded.

Or perhaps you can derive a solution from the macro snippet listed in 121536 – Embedding external (links) images programmatically no longer works?

Or you use Windows? Newer LO versions are available in 32-bit for Windows.


Thanks, Regina! The workaround, well, worked! :slight_smile:

Also, I managed to test in some other OS/LO versions combinations and most of them worked fine out-of-the-box. It must be that bug you directed me to.