I cannot change the language of a document in Writer

I am in Spain but writing in English, and the document language keeps resetting to “Spanish (Spain)”. I need to be able to use English (UK and US) and sometimes I do write in Spanish, but I would be fine with none at all.

I’ve tried changing it, and the best case scenario is that it changes back after I type the next word. Often nothing at all happens. I am not someone who can go into the code and make changes, and I’m new to LibreOffice, so I’m wondering if maybe LibreOffice is not for people who can’t change the code themselves. I’m skilled with MS Word so I’ve tried everything that resembles their interface, but nothing is working.

If anyone can help I’d really appreciate it!

When you say you have changed the language, have you used

menu Tools → Options → Language Settings,

and changed both the “Language of” and the “Default Language” ? Or did you use

menu Tools → Language,

and change one or several of the options there?

I used the latter, because in the former (Tools->Options->Language Settings) Spanish doesn’t appear as one of the available languages. I also tried just clicking on the bottom of the screen where it says “Text Language.”

changes back after I type the next word

That’s the reason. Just switch to the desired language.

I appreciate your help! But I don’t think my meaning is coming through because I don’t understand what you’re saying. I would like to change the language and have it stay in that language at least for that entire document. To be clear: I have switched to the desired language. I have selected English, both US and UK, and I have selected “none” (which is not my first choice, but if I have to do that it’s better than having the entire document underlined while I type it). It changes to the language I select, then after I type the next word it changes back, every time. I’ve tried selecting the entire document and then doing it, but same result. I’ve tried creating a new document and switching the language right away, same result. (It always says English to start anyway, then changes to Spanish.) I don’t know how else to describe it.


Yes, you have change the language of the present text. Now, switch the input language as needed to continue typing. As you say:

It always says English to start anyway, then changes to Spanish.

This means, most probably, that you type in Spanish. Switch to English.

I haven’t been able to duplicate your problem, but in my version of LO ( – I know I should update) there are 4 (4!) different places to make language settings.

Under menu Tools → Options → Language Settings → Language there are 3 settings :

  1. User Interface

  2. Locale Settings

  3. Default Language for Documents.

It might be Locale that is the source of your problem but you should check that all three are what you want.

There is also menu Tools → Language → For all Text. Make sure that it is what you want.

I hope this helps.

Thanks for looking into this! I checked this after your first response and they are all set correctly (to English), including locale. The document still says Spanish (Spain). I can change it in the field at the bottom of the screen but it changes back after the next word.

Thank you so much for your help! I really appreciate it.

To gabix:
I am typing in English, not Spanish. I know that I need to switch to English; that’s what I’m asking for help with. Thanks for your help.

About the language setting at the bottom of the Writer screen – If you haven’t already tried this, what happens if you select “None” there? Does that stop the switching behaviour?

In your document, modify the Default paragraph style and other paragraph / character styles to set English as the default language.

ve3oat – The same thing, although sometimes it doesn’t change it at all.

gabix – I don’t know how to do that. I can’t find a language option under paragraph formatting. If you mean under Tools → Language, then I’ve already tried that.

I think I’ve managed to get automatic spellcheck turned off so not everything is underlined, so that’s good (I don’t like to use that anyway), but I won’t be able to use regular spellcheck.


Are you working with Windows 7 or 10?