I cannot find an answer to disable auto increment

Cell G2 has a number in it, which will change often. In column B, I want B2 through B1000 to display the value in G2. So, I enter " =G2 " into cell B2. Assumed I could drag down and have it fill - it does but increments - G2, G3, G4 … Fine, I’ll also enter =G2 in B3, select B2 and B3, and drag those down. Nope, it increments. Everyone says its easy, hold the CTRL key down. Nope, no good for formulas I guess. Tried Fill Cells - Fill Series increment to 0. no good. Turned off AutoInput. How can the answer to such a basic task be so elusive?

To “lock” a part of the cell address, use the $ prefix.


The use of the $ address prefix is known as “absolute addressing”, as opposed to “relative addressing”. Depending on what behavior you require you can use a fully absolute address =$G$2, mixed absolute/relative =$G2 or =G$2, or the basic relative address =G2.