I cannot open .ods with double click

I have LibreOffice installed on windows11. While I can open a file with “open with”, I cannot assign the extension to open with LO.

When I enter into configuration of Installed Applications, Default Applications, Choose default applications by file type, there is no file type “.ods”.

I have repaired the installation and re-installed, but it seems that the file type is not being registered in the Windows Registry.

A Custom intallation works for me on Win10 (I have not W11 yet): in a specific step of the Custom installation you can choose the file association options.

Thanks; I will re-install again and see if I missed that step.

It should be possible to make this permanent, as there is usually a checkbox “open always with” this program below the selection-list for applications.

1 Like

I agree. That is why I am surprised that when i “Open As” there is no option for “always”. Nor does the extension exist in the control panel for associating programs with known extensions.

Installed LO again. Version 7.5.3. There was an option to associate Word and Excel file types, but not .ods. Dot ods is LO native format, so one would expect it to be included.

In the control panel under applications I can see the file types that LO will open, but .ods is not one of them. If I create a file in calc, the default file format is .ods. And I can open said file with “open with” but the icon shows that it is assigned to Notepad. In the control panel under application I can search for file types and assign them to programs of my choice, but .ods is not on the list so it cannot be assigned to a program.

This really smells like a registry problem, but I am not sure how to hack it.

FYI: I used the SetUserFTA utility to change the file type association and it seemed to work fine. Better that than botching things up in the registry.

The LO install program (downloaded from various sources, with various browsers) was not able to establish the association. Same program on a different windows 11 machine worked.

Thanks everyone for the help.

Run Windows 11 “Settings” and click on “Apps”

In the top box on the right enter “ods”.

It should show “LibreOffice OpenDocument Spreadsheet”.

If it doesn’t, scroll down the list of apps to find LibreOffice and select it.

If it already shows “LibreOffice” I don’t know what the problem is.

Thanks for the suggestion. I have tried that and there is no file type .ods. Therefore it is not assigned to LibreOffice. So, it is assigned to Notepad by default and I have to way to assign it to another application as it does not exist within windows. There are many file types assigned to LibreOffice, but not .ods. To me it seems as though the extension .ods has not been added to the registry.

Maybe best to download the installation file again. Right click it and choose Show More Options > CRC SHA > SHA 256 and check that it matches the number listed in the link info just below the download button on LibreOffice website. If all good then run the installer from Windows Explorer, not Edge.

Good suggestion; I will give it a try.

Ok, I gave it a try. I downloaded the program again in various explorers and the checksum look correct. I tried downloading a previous version. But .ods still does not look to be registering correctly.

I am searching for ways to hack the registry.

Seems it is to late for this, as you use Win11. I’d try “assoc” and “ftype”. See explanations here:

I found the above link at

As there was also a tool to set the FTA mentioned, I googled for its origins and cam to this blog, wich shares some background:

That suggests that something went wrong with the installation of LibreOffice.

It is probably possible to edit the registry and add .ods, but I am not qualified to advise you on how to do that.