I cannot update to LibreOffice

On trying to update I am getting various failure messages from the Installation Wizard, viz ‘Error 1714. The older version of LibreOffice cannot be removed’ - it isn’t installed. Also, I have got the following message ’ Cannot find C:\Users<username>\AppData\Local\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\TempState\Downloads"older version of LibreOffice".msi’
I’ve looked to check various paths and looked for obvious ‘junk’ without success. I have then uninstalled the earlier version of LibreOffice, all to no effect.
The latest effort has now given the message “Error 1714. The older version of LibreOffice cannot be removed. Contact your technical support group”
Any suggestions gratefully received.



just to name a few, if you enter “1714” into the search box of this site.

Thank you, but no luck. I have tried all of the available solutions but no success
OS is Windows 10. I save and launch the package from I:/ drive, installing to same (via custom installation) to save space on my SSD. Saving to c:/ makes no difference. I di note that the custom installation option has an ! in the shield symbol. Any significance?

I’ve tried all of the following (not in any special order, just as I remember them):

Downloaded package has the correct checksum
Uninstalling the old software makes no difference
Clean booting the PC
Searching the registry for LibreOffice and deleting all entries (after saving the old registry)
Renaming the I:/ folder location with an ‘old’ suffix and establishing a new folder
Running Microsoft troubleshooter doesn’t seem to help as LibreOffice is not in its listing (no surprise there)
Forcing MS Update makes no difference

I get various failure messages, 1714 is the common one. Why does it want to remove the package I’m installing?