I can't switch top ruler view.

Hi. I’ve heard many great reviews about libreoffice but I’ve faced bugs very soon. I can’t switch top ruler view to inches or to centimeters. It always stay in millimeters. I thought I’ve done something wrong and tried to find answer on the help page but I couldn’t open one. Instead of the “rulers - measurement units” opened the “tab stops on rulers”.Later I found out all pages didn’t work and I always got the “tab stops on rulers” :laughing:
There’s one more problem: I changed a color of page numbers and saved a document but when I opened a file again the color stayed by default. It happens every time.

Windows 7 64
LO 6.1.4 or 6.0.7


How do you proceed? The double-click in the ruler opens the dialog for defining tabs.

The unit change is done via the ToolsOptionsWriterView menu.


Thank you for help. Really weird. I tried the right click in the ruler and it didn’t work properly but when I’d changed value in the options the right click began work correctly.

Ok, thank you for feedback :slight_smile:

By the way. It looks like I found out why a color of page number can’t be saved. Maybe docx format can’t support this function.

The problem with the ruler is not solved completely. When I open a new document the ruler stay in millimeters by default. At least now I can change it manually :laughing:

well, if you have trouble saving/modifying options, it seems you have a “profile” problem. You can try to restart in “safe” mode: Menu HelpRestart in Safe Mode. See also this FAQ.

Safe mode didn’t help. I installed fifth version of libreoffice and this work correctly now. How can I help to fix this bug?

Submitting here & documentation here