I do not find the menu bar

I am new to the LO fork, although I have been using Open Office for almost 20 years.

I have LO 7.0 in Linux (PCLinuxOS)

I do not find the menu bar across the tops of the windows (File View Edit Tools… etc) in either Writer or Calc. There are just the two toolbars. It was present in earlier versions that I’ve now overwritten.

Don’t tell me Tools>Options etc as I cannot access Tools!

???

This may be caused by a discrepancy between the widget handling driver and the widget used by your desktop.

Open a terminal and type SAL_USE_VCLPLUGIN=gen soffice --writer with the exact casing shown. Sometimes the binary is named soffice.bin; it depends on the distros.

Do you get the menu bar?

If so edit your question to tell which desktop you installed (there are many, KDE Plasma, GNOME, MATE, LXDE and Xfce are the more frequent). Check also which widget handling packages are installed. I know of libreoffice-gtk3 for GNOME, MATE and derivatives, libreoffice-kf5 for KDE, libreoffice-x11 (is a generic one, UI quality is poor but works everywhere). The names are for Fedora distro and may vary.

By the way, you can access Options by pressing Alt+F12. Tested with LibreOffice 6.4.7.2 (x86); OS: Windows 6.1.

Works also under Linux

Sometimes the binary is named soffice.bin

The binary is always soffice.bin; however, there’s also a soffice and/or libreoffice wrapper script (and maybe some symbolic links under different names) that should be invoked instead, which set a runtime environment. The soffice.bin should not be invoked directly.

@erAck: thanks for the info

You may have unwillingly changed the GUI mode for a rather experimental one mimicking M$ Ribbon.

See if you have in rightmost position of second toolbar a menu with name Menu or View. Both Menu and View have a check box for Menubar.

In the tabbed modes, click on the View tab and this will bring a Menubar button in the lower toolbar.

Once you have recovered the menu, revert to the usual GUI with View>User Interface>Standard Toolbar.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

@ajlittoz, I just edited the title. Make a change into your answer, so your username appear at the top, and delete this comment.

Curioser and curioser! I have now found out where the missing tabs end up: they appear as widgets in my top panel, but not instantly, only after I have carried out some operations – the most reliable way to get them to appear it to edit the panel and they pop up. This is enough for me, as all I really want is LO’s ability to save calc files in .xlsx format. I have spent 20 years learning all the nooks and crannies of OpenOffice and don’t wish to spend another 20 doing the same for LO – I’d be over 100 by then! (I use AOO to edit a botanical magazine with many embedded images and the files don’t open correctly in LO, the pictures are all over the place.)

I tried ajlittoz’s SAL_USE… command and it opened OpenOffice not LibreOffice, they clearly use some identical file names. I then wondered if the problem was that I had both installed, so I completely removed both and then reinstalled LO – still the same.

I have two parallel OS’s in different partitions each with access to the same data files and Mozilla profiles. One for everyday use and the other for testing. Both are regularly updated. The OS’s have KDE5 plasma desktops. I don’t find libreoffice-kf5 or anything like it in a search of installed software using synaptic – as it’s not installed maybe that’s the origin of my problem. (I used the LibreOffice Manager to install it and assumed it knew what it was doing.) I will bring this up in the PCLinuxOS forum.