I get a soffice.exe error

Hi. I’m new to this forum so apologies if I make any errors. I have been using LibreOffice 6.4 for a while and noticed there was an update (7.1) available which I installed. When I try to open it I get a soffice.exe error saying that VCRUNTIME140_1.dll is missing and that reinstalling may fix it. I have tried that and gone back to the previous version (which did work) and get the same error message. Does anyone have any suggestions to get this fixed? Thanks.


install the latest supported Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017 and 2019 from here https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads (most probably you need vc_redist.x64.exe (Windows 64-bit)

Hope that helps.

Thanks Opaque. I’ll give that a try.

That worked. Thanks again Opaque. I am left wondering though whether the install/reinstall of LibreOffice actually deleted the C++ that was there already as the earlier version of LO had worked.

Hello - not yet clear but there is a bug report #tdf134849 - Libre Office RC1 installation crashes - a renewed installation goes to the wrong folder - Libre office 6.4 doesn’t start with renewed installation after uninstall of RC1 - error: vcruntime140_1.dll missing in UNCONFIRMED state, which might apply to your case as well.

*If the answers works for you, please consider to click the check mark (✔) next to the answer. Thanks in advance ...*

That sounds exactly what happened. LO 7 now seems to work ok now that I have reinstalled C++. Thanks again for your advice.

See also #tdf135579 - Deinstall of LO on Win7Pro also deletes “VCRUNTIME140.dll” for more explanation what might have happened (Hint:“DLL reference count”)