I get "General input/output error while accessing" when trying to open a file on an NFS share

I’m running LibreOffice on Xubuntu (Linux) 13.04 64-bit.

I have a Windows 7 x64 box that provides NFSv3 shares on my LAN via haneWIN NFS Server 1.2.11.

My Linux boxes mount these shares via fstab. Example:

jarvis:/Shared /mnt/jarvis/Shared nfs udp 0 0

When I try to open a .ods spreadsheet on the share (which was created in LibreOffice on Windows), I get an error popup that says “General input/output error while accessing” followed by the filename.

Why is this happening? It’s not a general share issue, as I can open the file in Gnumeric just fine.

I’ve read that it may be a locking issue, and that commenting out the following lines in /usr/lib/libreoffice/program/soffice may help:

# file locking now enabled by default

In fact, it does help, but why is it necessary to make such an arcane change to a system-level file?

Update: Mounting with oweng’s fstab options does not solve the issue for me. This may be because of a difference with HaneWIN, such as the fact that it only implements up to NFSv3.

Thanks for testing all the same. I agree that you should not need to make such a change as disabling file locking. Particularly given what it says in the readme: On a network that uses the Network File System protocol (NFS), the locking daemon for NFS clients must be active.


I contacted the haneWIN developer, and he confirmed that haneWIN does not implement locking. He suggested mounting with the “nolock” option; I thought I had tried this before without success, but I tried again and it worked:

jarvis:/Shared /mnt/jarvis/Shared nfs nolock,udp 0 0

Thanks for looking into this. Once you get enough karma points, please accept your answer as correct. I’ve marked your question and answer up to get you part way there.

I have no issue here using NFS. This is what my client /etc/fstab entries look like:

server:/place/on/server  /exported/mount  nfs auto,user,soft,rw 0 0

Admittedly I am running a GNU/Linux server with nfs-common v1.2.6-3.