I have been unsuccessful in my attempt to print a nbr 10 envelope

using a brother hl2240 laser printer, libreoffice writer fedora 17
it comes out with the printing parallel with the short axis of the envelope

I start by defining my page as a commercial 10 envelope
it shows the right size page with printing along the long axis of the envelope

I tell it I will do manual feed and open the straight feed doors on the front and the back and toggle the green levers in the back, set my guides to the short dimension of the envelope. It takes my envelop from the manual feed slot and prints on it at right angles to the long axis. it is as if the printer stays in portrait mode when it needs to shift to landscape.

I have tried telling it portrait, landscape - no difference

for what its worth - unless i’m wrong - this feature worked perfectly with my hp laser and open office

I wonder whether the brother printer behaves differently than other printers, since I can’t imagine that this problem occurs with all the people using libreoffice.

Any suggestions?

In the search box at the top of this page enter “envelope” and take a look through some of the previous questions on this same subject.

Yes - LO has some problems handling envelopes. Generally I have found that you need to set the printer preferences when you define the envelope. Insert - Envelope and then the Printer tab. In addition to the orientation, also do the printer set up from that tab.

Good luck - it takes some experimentation - probably different for each printer model.

JohnD - Bingo
I searched for envelope as you suggested and found an article “Envelope Printing Rotation” - the work around was change the output from pdf to ps

I did and it did!!

The problem is solved - so to speak - by selecting postscript output instead of the default pdf output!

I neglected to mention PostScript (over PDF) in my answer below. This is first thing to check for, so sorry about that. I am glad you found a solution. I have marked your answer up.

To add to the answer from @JohnD, bug FDO#51132 may be related and offer a workaround.