I like having a light green background i Writer because it is easier on my eyes, but I don't want that background to print. How do I create a non-printing background that will be set as te default page style?

This is a technical question about how to create non-printing page backgrounds in Writer.

Look once in the menu Tools>Options>LibreOffice Writer>Print. Do you have a check mark on “page background”?

If my answer did solve your problem, please click the big checkmark inside the circle image description to the left of this answer. It then indicates to the other participants that the question has been answered correctly.

With me Windows 10 Home; Version 1809; 64-Bit | LibreOffice, Version: (x64)…

Under Tools → Options → LibreOffice → Application Colors you’ll find the settings of all colors that apply to the program, not to the document: change “document background” to any color you want, that color will not go to print nor to PDF export.