I paid a donation to LibreOffice but it still doesn't download

cannot-download, I paid a donation

As previously stated, downloads are independent of donations:

Did you perhaps just not notice that the download started automatically? Some browsers don’t make it very obvious.
If the download did not start automatically, did you manually click on the link? hint: the link is the filename in green in the line near the top of the page:

Your download LibreOffice_5.1.2_MacOS_x86-64.dmg should begin shortly. Please click the link in case it doesn’t start.

Hi, which version where you trying to download. Have you tried alternative links?

This is the main page for download:

This is currently the link for linux deb64 http://donate.libreoffice.org/home/dl/deb-x86_64/5.1.3/en-GB/LibreOffice_5.1.3_Linux_x86-64_deb.tar.gz
and this for Windows:
just two examples.

Alternatively you can use torrents, respectively:


Let us know if they work for you!

If this answers your question please remember to mark it so for the benefit of all the community. Thanks