I save in .odt, but it comes up in my saved files under docx.

I am a freelance editor and I have been using LibreOffice successfully for some time. However, tonight I sent a corrected document to a customer and she called to say that none of my corrections are showing up. I tried saving again, and I am noticing that when I try to attach the corrections to an email, I’m not given an .odt option. It’s coming up as Windows. I need a suggestion as soon as possible because I have a client waiting for me. I’m not particularly techy. My son helped me get on LibreOffice, but he’s busy tonight, so please make your answers understandable to a layperson!

Most likely it’s not “coming up as Windows” but rather “… as Word”.


  • Microsoft Word does support the odt storage format.
  • If Word is installed, the installation procedure will register it as default handler for the odt format.
  • Virtually every Windows computer sold to consumer, and most of those on the pro market, will have a MS Office “trial offer” preinstalled, which will do the same thing.
  • If you haven’t uninstalled every single MS Office component, there is a chance that some software update will determine that “there is a problem with the current odt handler”, and set it to Word instead.


  • Go to Settings - Apps - Default apps.
  • Click pick default app by type (you may need to scroll down a bit to find that link)
  • The list of file types usually takes a few seconds to build. Scroll down to the od* types and set them to appropriate LO apps.


This only fixes the issue on your computer. The receiver of your files may have the same issue.

Also, it may be that the problem lies with the mail service you use, and not your own system. The solution above will not work if the mail app/service does not observe local settings on your computer.