I want to be able to set the font that I use everytime

I get pissed off with this bloody program because it always defaults to New Roman that no one uses, least of all me.
There is a very valid reason why fonts have been developed specifically for use on computer screens because of the pixel dots. New Roman does not work on computer screens because of the little tails on the end of the letter strokes.
I want to use the calibri font that gives a clean easily read text on the screen.
How do I set Calibri as my default font, and the size that I use?

You shouldn’t get angry with a program for using defaults. :slight_smile: (And this question has been asked about before - did you search for “default font”?) There are two ways to do this, but the most important one from what you describe is the first:

1. Set Default Font

Go to Tools > Options > LibreOffice Writer > Basic Fonts (Western):

That’s the main one you want so that you’ll get Calibri instead of Times New Roman.

2. Using Themes/Styles

F11 toggles the “Style” panel. You can set all these styles to have their own parameters, including choice of font. There is quite a bit of info on using them, here in Ask LibO, and also in the documentation (see ch. 6, “Introduction to Styles”, and ch. 7, “Working with Styles”).

You can also set up a page the way you like it, then save that as a template for future use with those options as defaults on a document (rather than system) basis.

Lots to explore here, and it’s fairly powerful and simple – after the first time, of course!