If I have a page formatted as 2 columns in Writer, how do I switch between columns?

I have a page formatted as 2 columns. How do I switch between columns?

You don’t switch. You add contents, and it flows to the other column, Or you insert a column break to force that.

Mike: that’s not a comment but an answer.

I have the same question. When I create 2 columns and use ‘newspaper style’ (deselect evenly distribute contents…) I can add text to the left column but not the right column. I can’t figure out how to get the cursor into the right column.

I was able to make ‘newspaper style’ columns work by inserting a column break [Insert → Manual Break → Column Break] in the first column. Once the column break was in place I could access the 2nd column.

I don’t know if this is the best way to access the second column, however. It seems that ‘newspaper style’ columns should automatically allow access to the 2nd column.

You have 2 ways to format multi-column: define several columns in page style or section and insert a multi-column table. Both methods have pros and cons. They have their own idiosyncracies and workflows. The choice depends on your purpose, notably automatic flow from one column to the next or not, and relation between columns. Experiment to see how it fits you and how you feel comfortable with them.

(See also the comment by @mikekaganski to the Original Question.)
Pages aren’t fix objects of the document. A new page is started when needed because the the previous page flows over. You can force the start of a new page by insertion of a manual page break.

In the same way the next column gets started if the previous column flows over.
You only can force this prematurely by inserting a manual column break.
The start of a new column because a rightmost column flows over will also start a new page.

The only difference insofar is that columns to the right of the one currently being filled are already foreshadowed in the view in advance of being started. That’s just a hint concrning the page style.

For the sake of completeness: the Evenly distribute contents to all columns section option (found on Columns tab) control the order in which columns are filled. If not set, then first column grows until end of page reached, then second starts to be filled. Otherwise, naturally, as lines are added, they get rearranged between the two columns.

@mikekaganski: Thanks for the amendment!
I would, however, like to emphasize that the mentioned option is available for sections only. Columns introduced via the page style cannot be filled this way.
Just for completeness I now also mention the Direct Cursor Mode available since V 6.0 from the Edit item of the main menu. (It may be seen as another temptation to fall back into the habits of typewriter times.)

Thanks for all the replies. Issue closed.

Unfortunately you didn’t mark the correct answer, so that others could know what to use; and also posted your comment as yet another answer - which should be avoided: answers are for answer to the original question.