IFS function not working in OpenOffice 4.1.9

Hello guys,

I updated to OpenOffice 4.1.9, resulting in an error in all the IFS functions of my existing .ods file.

The file worked in the previous OpenOffice version.

Opening the file in the new OpenOffice version changes the formula from =IFS… to =com.microsoft.ifs(…

(see screenshot)

image description

My example file is attached below, too.

I’ve tried the following:

  • manually replace =com.microsoft.ifs(… with =IFS which changes into =ifs after pressed ENTER

    - create a new spreadsheet and type in a simple IFS formula results in =IFS being changed to =ifs after pressed ENTER

I tried @erAck’s solution to a similar problem, but it did not work for my problem: Importing IFS() and CONCAT() from Google Sheets into Calc

My question:

Does anybody have a solution?

Also, I do not find the IFS function in function Wizard. Does the current OpenOffice version got rid of the IFS function all together?

test file:

Thanks in advance as always


Note that Apache OpenOffice is a completely different sister project, forked from the same origin from which LibreOffice was also forked - OpenOffice.org (so the two projects have the same ancestor, but are diverging in their functionalities; or rather, one (LibreOffice) is evolving, while the other (AOO) is basically stalling).

Thank you!

OpenOffice does not support the IFS() function. Use LibreOffice.