I'm unable to keep font color while exporting to pdf in Writer

Font in my odt file is not black but always get exported as black. How can I maintain original font color ?

I made a short video to demonstrate the issue, https://vid.me/Ksg

Tools > Options… > LibreOffice > Print > Reduce print data section > ensure “Convert colors to grayscale” is not checked. If that does not work, can you edit the question to upload or link to an example for others to test?

Additionally, you have to make sure that “Print text in black” is not checked on the Print dialog > LibreOffice Writer.

Many thanks for this comment and fix. Unchecking “Print text in black” did the trick.
Enabled me to publish a technical article in PDF format that I’d spent hours on, without losing
all my color-coded syntax. But why is black PDF text the default?!?