Image import in LibreOffice fails if filename contains non-latin characters


When I try to import an image into LibreOffice and the filename of that image contains non-latin characters like (I tested with Polish characters), I get an error window saying “Nonexistent object. Nonexistent file.” and “qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 4541, resource id: 37810746, major code: 40 (TranslateCoords), minor code: 0” in console (in Impress) or “Image file cannot be opened” and “kf5.kio.widgets: No node found for item that was just removed: QUrl(“file:///home/piotr/Dokumenty/Prezentacja MCHTR v2 %3F%3F.odp”)” (in Writer).

I have installed all available language packages and all format locales are Polish, however all my display localles are English (makes it easier to solve all sorts of problems using a search engine). Is there a way to fix that behavior or is renaming the files my only option? Thanks for your time :slight_smile:

My system:

Operating System: Manjaro Linux
KDE Plasma Version: 5.15.5
KDE Frameworks Version: 5.59.0
Qt Version: 5.12.3
Kernel Version: 5.1.8-1-MANJARO
OS Type: 64-bit
Processors: 12 × AMD Ryzen 5 1600 Six-Core Processor
Memory: 31,4 GiB

Edit: LibreOffice version

Build ID: 6.2.4-1
CPU threads: 12; OS: Linux 5.1; UI render: default; VCL: kde5;
Locale: en-US (C); UI-Language: en-US
Calc: CL

… and your LO version is … ? :wink:

Right, sorry for that… I edited the OP.

Given that you use last version, please file a bug report to bug tracker.

Sure thing. You can find the bug report here: Bug 125971.

Thanks :slight_smile: