Images gone in pptx created and saved in impress

As described in title, I created and saved a .pptx file in Impress, that was fully functional the last time I’ve worked on it.

Today, I opened it, to work a bit more on it and, to my surprise, all images were gone.
They’re complete ghosts!
The file is 16,4MB large, which means the images are obviously there, they’re simply not being loaded/displayed.

I’m using the latest version of LibreOffice, downloaded and installed today.
It’s not this latest build that is causing the problem, was the one I had previously installed, which was the latest build before this current one.
I updated to this latest, hoping it would fix the problem, but it did NOT!

I’ve also searched for fixes here and, although I saw some similar problems, I saw none that would actually depict the very exact problem I’m currently having.

I’ve also tried opening different backup copies I had previously made.
I’ve also tried opening the file directly on PowerPoint, on different machines, with different versions of Office (2019 on Desktop, 365 just installed on this Laptop).
The only difference I can see is on PowerPoint I can actually see the ghost-images “boxes”, while on Impress it seems the images are absent and most of the slides are completely blank, when they’re not.

I’d very much like to upload the file here, so you can see for yourselves, but I do not believe I have the option to…

I have to make a Presentation on next Monday morning (May, 23rd) and I’d just hate to have to rebuild the file, cos it’s 45 slides, most of them have images and it will take me HOURS to get it all redone.
Besides, if this is a bug, there has to be a permanent fix for it, right?
None of the fixes I’ve read on here apply to me, possibly for being way outdated, but I just can’t seem to find any fix for this, so, if you guys can help me with this, I’ll surely appreciate it!

I’m using Windows 10 on both machines (Home on Laptop, Pro on recently acquired and not yet fully configured Desktop)

You may be using an older version of LibreOffice. I just tested pptx and there were no problems at all.

Please upload your file here. If pptx is not allowed, change pptx to odp.
When downloading, odp must then be changed to pptx.

It could be a compatibility problem between
ODP and PPTX .


Recommendation for clean working with LibreOffice when different Office programs are used.
Always create and save your files in LibreOffice and save them in ODF format (ODT, ODS, etc.).
Always keep these files as their source.
If you need other formats for distribution to partners, you can open an ODF file and save and distribute another format with ″ Save as… ″.
This way, you always have working files available in your system environment.


Edit different file formats in LibreOffice

Please report the behavior as a bug in Bugzilla .

See also:

How to Report Bugs in LibreOffice .

Please post the link from the bug here.
format: tdf#nnnnnn (use only the number, not the link)
To do this, edit your initial question. Thank you.

You saved in PPTX and you must have seen this warning:

Hrbrgr, thank you.

Max File Size is 4MB, so I need to share from my Drive.
Link is: Google Präsentationen wird geladenVILA VITA.pptx
I’ve just uploaded it.

As I explained on the initial post, the file was created on an older version of LibreOffice.
Then I updated it to the last build before this one, worked on the file and it was fine, nothing missing, no ghosts.
Today, again I opened the file, to work on it and it’s all ghosts, regardless of where I open it, with what, on whatever machine, already updated to (x64) Build 19044 and the issue remains.

Microsoft Office was NEVER installed on this laptop, so there can’t be any incompatibility issues or mixups or whatever else.
Office 365 was installed just before I created this topic, after having also tested directly on Powerpoint.
Same result: Ghost-Images, as I’m sure you’ll be able to see for yourself…

Thanks again,
Best regards,

I downloaded your .pptx file and opened it in Impress
The good news is, the images are all there.
Open your file in Impress.
Open the sidebar, menu View>Sidebar ( Ctrl+F5 ).
On the far right, select the “Navigator” icon.
There you will see the individual slides and the images they contain listed.
However, the images are all set to Tranzparenz 100%.
This is the reason why they are not visible.
Double-click on an image in the Navigator.
Click on “Properties” on the right sidebar.
At Image → Transparency enter “0” (zero).
The image should be visible again.

Please save in ODP !

There can and there are.
Assume LibreOffice is working internally in german language (inherited from star-division). When you save in odf-file german language is used. If you save to pptx-files of Microsoft everything is translated to for example some Shakespeare-english and has to be translated back by another translator, when you open again in LibreOffice.
These transformations are not perfect, so you may add small changes to your product by every save and reload cycle.

So avoid this by working and saving in LibreOffice and odf-Formats only and export only the final version as additional copy - as @Hrbrgr already wrote.

1 Like

Hrbrgr, thank you so much for your help! :slight_smile:

Problem fixed and solved! :slight_smile:

What I don’t get is how that thing got that way, it absolutely makes no sense to me, cos I didn’t do it, but hey…! :slight_smile:

1 Like

Wanderer What I meant was there could NOT be any incompatibility issues between Office and LibreOffice, if/when Office was NOT installed.

And, actually, there are NOT, despite your explanation.
If such odd occurences are taking place, from your explanation, what we can see is that it is a structural flaw and not exactly a bug.
And the more Languages in which LibreOffice is available, the higher the probability of such odd occurrences taking place, specially when you work on a file at different times, making additions each time you open it, until the task is complete and the last Save is final (which is exactly how I built the file)…

Being a non-active QA Tester myself (did it for years, not anymore and NOT regarding this particular software or its “parent”), I, therefore, cannot see this as a bug, to be addressed via a regular Bug Report, but rather through Engineering instead, because it’s Structural, not Code Integrity.

Again, IF it is what you identified in your explanation.
I don’t know if it is or is not, I never really used LibreOffice in “Tester Mode” and even as a user I didn’t really use it that much, until recently, having now a need to do so, when I didn’t before.
However, based on my QA Tester background…

LibreOffice is not MS Office, see [Tutorial] Differences between Microsoft and AOO/LO files

EarnestAl Really!?
Have you read what I’ve written?
Did you understand what I wrote?

I only tried to give a picture to be understood by non-programmers, as I didn’t know you have any knowledge there. So I was not referring to actual languages but to different structures in “languages” to express file-format/style-concept/… Not important as your issue is solved.
But if you ever have a problem, wich can be reproduced consider a bug-report, because LibreOffice does imho not provide separate channels for issues wich “need enginering”. Also requests for features or enhancements requests go through bugzilla.

1 Like