Impress 3.5 - problem adding "Other Sound"

I run several installations of Linux, Ubuntu 11.10, 12.04 (rc), Mint etc.
On 11.10 I have LO.o 3.4x and all is well. On an XUbuntu 11.04 the same applies. However, Mint 12 and !!.10 upgraded to 12.04 I find the following with LO.o when I try to insert an MP3 sound file into Impress.

I select “Other Sound” and browse to the relevant file but when I add it to the slide, the notifier immediately returns to “No Sound” and the mp3 is not added. If I select one of the pre-selected sounds (e.g. apert.wav) it inserts correctly. I have tried inserting a wav file and also moving the files to the same directory as the pre-selected ones but have had no joy.

I have loaded all the GStreamer packages and can play the files in VLC, MPlayer etc.

It’s a show stopper for our church if this can’t be cured - currently I resort to finishing the odp on a machine which does allow me to insert the slide transition Other Sound which then plays on any machine.

Hi Anonymous,

Please try upgrading to our latest release and see if that fixes your problem.

If you’re still experiencing issues, please file a bug report and provide as much information as possible. The QA team will be happy to help you triage this issue in the bugtracker.

If you do file a bug, please post a link to it in a comment below using the format “fdo#123456”.