Impress 5.1 crashes in ubuntu 16.04 when embedding an avi file

I haven’t found anything about ubuntu 16.04 and impress crashing when embeddeing i.e. Avi files yet in the forum.
Ubuntu 64 bit 16.04 works great and media players play the avi file.
What information do I have to collect for trouble shooting?
Thx in advance…

Ubuntu probably collects debug information via apport … if you get a dialog box after the crash with a notification it may be apport reporting the issue.

It may help launching LO via command line (open a terminal Ctrl + Alt + T and there input libreoffice), replicate the crash and see if in the terminal there are useful informations.

If you would like to file a bug for LibreOffice then go to

I do have the same Ubuntu 16.04/amd64 and no problem with embedding AVI files, tried just right now to double check, Is it all AVI or a specific one?

Please click the check mark next to the response you believe best answers your question.


thanks for the answer!

in the terminal it shows:


(soffice:2885): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

(soffice:2885): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

(soffice:2885): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

** (soffice:2885): WARNING **: Invalidate all children called

** (soffice:2885): WARNING **: Unknown event notification 38

** (soffice:2885): WARNING **: Unknown event notification 36

(soffice:2885): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

(soffice:2885): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

Actually the file works absolutely normal in other ubuntu libreoffice constellations.
I also tried creating a new presentation. When choosing the avi-file impress/libreoffice crashes.

There is hope, because you got it working.
I will try several avi files now.
Any ideas for the output above?

Thx in advance…

Those all look like warnings about the user interface, maybe the one with the * at the beginning… Let me know if this is a problem with that AVI or all of them. What about MP4 or MPG?

mp4 an mpg work fine. all avi-files have a problem. when using totem, no problem.

just saw vlc also has that problem. any idea about that? is this a codec thing? but totem works well…

No idea but it is interesting. VLC should use own codecs not gstreamer as far as I know…
Now the first / quick workaround (not the best) is to convert the AVI. You can use avconv or handbrake which is easy and graphical. Few clicks and while you sort out the avi issue you can still embed your files.

Again you can try to run vlc from a terminal to see if any message gives some idea on the problem…

thx. I will report back the solution…

I found out that avis do not consistantly work on ubuntu 16.04. I switched back to 14.04 and after gstreamer plugin installation evrything works. I admit I also switched back to LO 5.0. Last problem I have: even if I adjust the video size the video will not play in full window size. it will play back in normal size. Only if I start the presentation from the actual sheet it will go in adjusted size (made it full screen). Do you have any idea about it?

I found an interesting information. My system uses intels new skylake processor with integrated graphic HD520. My resolution is full hd (no 1920x1080) non touch. In the following link the fullscreen problem in vls media player was solved and also worked for me: last entry in the forum the guy changes the automatic video output to ‘X11-Videoausgabe (XCB)’ and now videos play full screen.