Impress 5 not backwards compatible with Impress 4?

I have used Impress from Libreoffice 4.x.x with great success. Recently I upgraded the computer system, and installed Libreoffice 5.2.5 and am noticing a problem with all the .odp files I made with version 4:

When I open one, the Libreoffice 5 banner displays as normal, then the file opens as expected. I can see all the slides down the left column. So far so good.

However, when I try to strt the slide show with F5, it disappears off the screen and a few seconds later, I get a Libreoffice Document Recovery window telling me to press “Start Recovery”. If I do that, it works for a few seconds and tells me recovery was successful, then it comes back up on the screen. But when I press F5 to try again, the same Libreoffice Document Recovery window shows up again.

I tried removing Libreoffice 5, and rolling back to 4 and the files all open fine. Reinstalled 5 and all need an apparent impossible recovery. Is Impress 5 normally not able to open files created with Impress 4? With the sheer amount of files I’ve created with Impress 4, I’d stay with version 4 forever rather than retype them.

LO is backward-compatible. There may, however, be a bug that prevents a version from opening some files that worked OK previously. That’s called regression. It may be caused by, e.g., some specific kind of multimedia, or formatting, etc. Furthermore, it’s unclear from your description that the problem is actually with files, it may be with presentation mode itself, e.g. because of changes in OpenGL or something.

So, it would be wise if you first try more recent (testing) versions (like, or to check if this was already addressed in a following version, and if it is not, file a bug at Bugzilla with a sample attachment, and describe the problem there along with your hardware configurations etc., so that others could try to reproduce.