Impress animations not working properly

Most animations not working at all, some work in preview but not in slide & a few work as promised.
Using Ubuntu 16.4/LO

Problem occurs with both text and images. What am I missing here?
All slide elements are entered directly, not copied from other sources.
Run 2 identical computers (side by side) and problem occurs in both.

What file format do you save in?

Download and install a newer LibreOffice Version and try again.

In response to comments above:
Presentation is saved in the default .odp format.
Yes, I have tried using a newer version (on still another computer) and upgrading to Ubuntu 18.4.
While it improves some of the animations, it adds other issues to the presentation such as it will not play the same video files which now work on LO5; mp4 for example. They have tons of flickering lightning bolts moving across the screen which makes them unwatchable. Even changed the video format to a variety of types in LO6, including .ogg & .mov. I tried using the existing Impress presentation as well as making a new one with the same results. I have tried using different fonts, various image formats (.png, .jpg etc.).