Impress Bug importing pptx files with master layouts that cannot be edited or deleted without using microsoft office

the bug is when importing pptx files into libreoffice the power point slides show click to edit master text styles, first level third level and second level. i’m not the only person who has decided that this was a problem from a class mates presentation… Can LibreOffice please fix this bug!!!
It’s really important I have received power point slides for Ancient History from my teacher and they are 40mb! plus!!! i can’t convert all of the pptx files as it takes to long with online converters and saving them in microsoft office 2010 on windows as odp is a complete disaster… I am using an unstable development version of libreoffice 3.6 LOdev 3.6.0alpha0+ e9d045f-f8506ca-8a74106-f0d66f on a mac and I even have libreoffice 3.5 on ubuntu. it is really important that it gets fixed because everything else in the pptx file works really except this annoying bug!!! these powerpoints have more than 40 slides!!! can some help ressolve this issue??? instead of deleting the text one by one on all the slides… i tried saving these on mac office 2011, as a ppt file and it just crashed!!!1?
If a fix is released in a daily version unstable release of libreoffice on one of the mirrors even if its windows mac or linux… i can access that version and save those slides as an odp so that it works really well with libreoffice 3.5… on my ubuntu desktop as an odp file…

work around… deleted the bug and problem by deleting everything in master view in microsoft 2011 on mac… I think the problem is when someone opens a presentation as ppt file say for microsoft 2003, and then they save it as microsoft 2010 format .pptx it then gets all jumbled up with libreoffice… there should be an option (one button click) to delete all styles and charts and graphics and tittle and footer boxes in master view on libreoffice as well… (delete the whole master slide!) so its a blank power point canvas in master view. just by deleting all the slides and ending up with the last one as a blank white canvas. ( I don’t think you can do that in libreoffice for ALL the slides like you can in microsoft office. (even microsoft office can’t do that very well what I just described :slight_smile:
more information:link text there is my bug on I have also reported this bug on launchpad if you click my (link text) and hopefully this will get some attention, as it is a compatibility bug, between libreoffice and microsoft office.

Hi @ljelly, What’s the state of this problem? I see that there’s still an open bug in Bugzilla, however it looks like there have been some patches applied and (per Bielefeld), some problems fixed. Could you please test your files against the latest LO 4.0 build and let us know the result? Thanks!

Fixed in Future Versions of LibreOffice

3.6.5 and 4.0+

You should file a bug report on if one isn’t already there.

was going to post that url here but the last updated didn’t trigger when posting a comment.

Fixed in Future Versions of LibreOffice

3.6.5 and 4.0+