Impress/Draw navigator: auto-scroll problem and can I disable it?

When there are more slides|pages, between the currently active one and the one you want to jump to, for the title list range of the navigator to show them both, the following problem appears: as soon as you scroll out of the range where the current slide|page is still shown in the navigator, the navigator will auto-scroll back so as to force the current slide|page to be again within the displayed range.

  • That makes it, in effect, impossible to scroll/jump to any slide|page that is not close enough to the currently active one.
  • Looks like a bug to me (but maybe I might just not see the use case or reason for said behavior of the auto-scroll in the navigator)

The question is: is there a way to change that behavior or, alternatively, to completely disable auto-scrolling within the navigator so as to not have that problem?


  • to simply reproduce the problem, just create an empty drawing or presentation, insert more pages|slides than the navigator can display without scrolling, and try to scroll to the last page. It will automatically scroll back so as to show the first page (which is currently active), thus throwing the last page (which you want to reach) out of the range displayed in the navigator.
  • that auto-scroll problem happens affects the navigator but not appear in the slide|page pane. The problem with using the latter to scroll through lots of pages is that it’s much slower (especially with the mouse wheel) due to the page thumbnails being much higher than the page titles in the navigator and also due to the much slower rendering of the page thumbnails when scrolling through them in the slide|page pane as opposed to scrolling to simple text titles in the navigator.
  • tried both current Libreoffice 7.1 (“fresh” Appimage from and Libreoffice 7.0.4 (distribution packaged rpm) on Linux (mageia cauldron). Problem appears on both.