Impress incorrect font rendering in presentation mode

Hello everyone,

I’m using LibreOffice Impress for presentations including the TexMaths plugin for LaTeX integration (the integrated formula editor is not bad at all, especially its slightly latex-similar syntax is quite nice, but TexMaths’ formulas simply look much better). However, there is a problem with the font rendering: In the editing window everything looks perfect, but switching to presentation mode will display extremely ugly-looking fonts (not even anti-aliasing is missing, everythings looks pretty much like an extremely-low resolution scan) while the latex svg graphics look perfect.

I tried to find some help regarding this issue and I found a few comments that the hardware acceleration causes these issues. Hence, I deactivated the hardware acceleration and the fonts are rendered correctly. However, now all my TexMaths svg graphics look ugly. I tried to solve this issue as well, but I can only conclude that either I can enable the hardware acceleration and my regular fonts look ugly or disbale it and my latex stuff looks ugly… rather annoying :-/

More precisely, I’m running a Windows 10 / Linux dual boot setup and this problem only appears with LibreOffice 5.3.3 (x64). If I open my presentation with the Linux version of LibreOffice (current version from ubuntu 16.04’s repositories), I can do both, enable or disable the hardware acceleration, and my fonts look fine in both setups. My TexMaths figures look ugly as well when hardware acceleration is disabled, but this is not a problem, since there is no need to disbale the hardware acceleration. Hence, I have to conclude that there is something wrong with the font rendering if the hardware acceleration is enabled. Further, since in editing mode everything looks fine with enabled hardware acceleration, this issue only appears in presentation mode.

Can somebody help me out how to get nicely looking fonts with enabled hardware acceleration with the Windows version of LibreOffice Impress, too?

Thanks in advance!

I can confirm that the same happens here, on Windows 10 (not dual boot), LibreOffice Impress version . Specifically,

A screenshot from design mode:

So that looks good. However, in presentation mode, we get:

Maybe, the transparency of the red shape causes the problem? @Gibtnix, do you use transparency?

Is this perhaps related to ?

(sorry, can’t edit my previous commment any more :-/ )

If so - enabling OpenGL (Tools > Options > View in LibreOffice section > Check checkbox before “Use OpenGL for all rendering” should solve this. Apparently it might also disable some slide transitions (I don’t use those, so no problem for me, but YMMV).

No, I’m not using any transparency effects…

Maybe a short update: This issue still exists in LO 5.4 on Windows and appears (at least accoring to my experience) as soon as hardware acceleration is enabled; disabling the hardware acceleration is a workaround, however all SVG graphics are ugly rendered then…
Currently there seems to be no solution at all, either ugly looking fonts and perfectly looking SVG graphics or vice versa… :-/

This is kind of a brutal problem. The main point of Impress is presentation mode. Disabling hardware acelleration in Tools > Options > View is a workaround, but not long-term. Hope LO addresses!

Since disabling the hardware acceleration will result in ugly looking stuff like SVG-figures or shapes or whatever you might put on a slide, disabling it is not really a workaround… the only possible workaround is to export your presentation to PDF and present it using a PDF viewer.
By the way: I also reported this as a bug to LibreOffice, hopefully this helps to get it fixed:

Since I was unable to see the screen shots for some reason, I am not sure whether my problem is the same or different, but when I use the (very unimpressive) Impress under gnome (3.28, using Lubuntu 17.10 on a Yoga 2 Pro) in presentation mode the font rendering is a joke-- some characters appear correctly, while others appear much smaller and different. If you interrogate the characters as to their format (font, size, etc.) they are all the same, but some appear different.
Interestingly, this is a problem ONLY in gnome-- when I boot into Lubuntu, all is fine (looking at the very same presentation).

Following the hint here, I disabled hardware acceleration under Gnome (3.28) and that solved the issue. I would hate to have to do it, though, since I use Latex-set equations occasionally.

This is but one of many issues I have had with Impress over the years-- it is definitely the weak spot of LO.

Actually my issue was different and was only present in the Windows version; running Linux was fine but required the hardware acceleration to be enabled. However this has been fixed in LibreOffice 6, it now looks fine on both, Windows and Linux. Don’t know if you gave already version 6 or even the latest version from the LibreOffice PPA a try, this might be a better choice than the official ubuntu one for issues like this. Maybe also adjust the graphics options, especially try disabling OpenGL.