Impress: Long load times in presentation with many connectors

I’ve been using LibreOffice Impress to create slide decks for my work for many years now. It works well in many cases, but I’ve found that in presentations that have lots of connectors the program takes a very long time to become responsive. For example, this slide deck, when loaded, sends the CPU usage up to 100% (as reported by top) for about ten minutes before dropping down to a point where the program is usable. During that time, almost all operations will be slow and, in presentation mode, slides take multiple seconds to flip. After doing this, if I try starting a presentation from one of the middle slides, I have to similarly wait again as the CPU usage spikes up to 100%.

This has led me to splitting my presentations apart into multiple slide decks so that the wait times are lower, which interferes with the presentations I’m giving.

For reference, here’s the version information on my LibreOffice install:

Build ID: 1:6.0.7-0ubuntu0.18.04.10
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group

I’m on Ubuntu 18.04. Happy to provide additional information or other slide decks in which this behavior triggers.

About 10 seconds for me witth Version: (x64) Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8 CPU threads: 4; OS: Windows 10.0 Build 19608; UI render: GL; VCL: win; Locale: es-ES (es_ES); UI-Language: en-US Calc: CL
Try with a clean profile Menu/Heko/Restart in Safe Mode, or update the version, 6.0 it’s a bit old.

About 5 seconds incl. start of Impress using a double click in Files (aka Nautilus) in a Ubuntu 19.10 Virtualbox guest using

Version:, Build ID: 1:6.4.3-0ubuntu0.19.10.1, CPU threads: 4; OS: Linux 5.3;
UI render: default; VCL: gtk3; Locale: de-DE (de_DE.UTF-8); UI-Language: en-US,Calc: threaded

Slightly slower (8s) it is on Ubuntu 18.04 Virtualbox guest using:

Version:,Build-ID: 1:6.0.7-0ubuntu0.18.04.10,CPU-Threads: 4; BS: Linux 5.3; 
UI-Render: Standard; VCL: gtk3; Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

This makes me suggest, that you should try to load your slide deck, while running LibreOffice in Safe Mode (Help -> Restart in Safe Mode...) to test whether your LibreOffice user profile could cause this problem.

Thanks to the commenters for the suggestions. Turns out that resetting my profile and upgrading to the most recent version worked like a charm here. I don’t know what specifically was messed up in my settings, but the load times have dropped impressively and it looks good to go. Thanks, all!