Impress: Mixing Pagesize in slide deck

My slide deck is mostly presentation slides (odp), but I would like to mix in a few whole page diagrams that are odg. If I add the odg to the slde deck as add slide from file, I get the choice to either scale it or essentially truncate it to the smaller page size. Neither works well.

Is there some way to just get it to display the odg as it appears from slideshow in the drawing part of impress?

“Do you want to scale the copied objects to fit the new page size?”

  • If do you click Yes you will get the part of the objects that lies between the margins of the .odg. Do you wish to get the whole page? Set the .odg margins to 0.
  • If do you click No you will get the part of the objects that lies from the upper left border (not margin) of the .odg, without scale.

Tested with LibreOffice (x64); OS: Windows 10.0.

Add Answer is reserved for solutions. If you think the answer is not satisfactory, add a comment below, or click edit (below your question) to add more information. Thanks.

Check the mark (Answer markCorrect answer mark) to the left of the answer that solves your question.

If the answer helped you, you can mark the up arrow (Upvote mark) that is on the left (to vote, you need to have karma of at least 5).

No, I was aware of those options. The drawings look bad compressed. What I just noticed is that I can change the page size in settings to “letter/portrait” and then diagrams display properly in slide show. However, then the text slides are letter boxed on the sides. Is there anyway to do this without making two presentations with different page size, or toggle between pagesize during slide presentation.