Impress presentations: Video autoplay and animation preview

Hello everyone,

I regularly use LibreOffice Impress (currently running version for presentations and I noticed two issues that can be pretty annoying.

The first one refers to embedded videos… I noticed that Impress shows a multimedia toolbar in the editing view, but as soon as the presenter console (i.e. full-screen presentation mode) is running, the video starts immediately and there seems to be no option like “start on click” or similar. I found the same question here (Link closed as “answered” but paradoxically there is not answer… ? If this is fixed so far I would appreciate to know the solution :slight_smile:

My second issue deals with the presenter console as well and here I noticed the following: If I create a few slides including appear animations, I will not see the next animation in the preview window it always shows a full preview of the next slide which can be pretty annoying. For instance by switching to a slide containing 10 bullet points that appear once after the other, I do not see a preview of the next ones after the first appeared, the preview always window shows a preview of the next whole slide (which actually appears after the remaining bullet points). This is extremely annoying as sometimes I do not fully remember the slide structures… PowerPoint for instance does a better job here since it always previews the next point to appear and only previews the next slide as soon as the last point appeared. Is it somehow possible to get the same behavior with Impress? I did not find anything related to this issue, so I’d like to ask here :slight_smile:

Thanks in advance!

That issue is actually a real problem for me as well. I am just preparing a slide show for a talk on a 1000+ conference with LibreOffice, but the feature NOT to start an embedded video automatically is crucial for me since I need to explain a few things that are visible in the first frame of the video. Bummer, this could have been nice opportunity to showcase LibreOffice (everybody else will likely use PowerPoint)…

(Adjunct professor at University of Helsinki)

Same issue here. The workaround I use is to add a duplicated slide without animation after the animated one, which will be showed in the “Next slide section”.

For your first question there is a solution with a little workaround.

  1. Add you media to the slide
  2. Add an animation for the media
  3. Choose Category “Misc Effects”, “Toggle Pause”; and choose Start “with previous” (that’s a bit counterintutive, because it’s the first animation)
  4. Add another animation, Category “Misc Effects”, “Toggle Pause”; this time choose Start “On click”

Now if you switch to the slide in presentation, the media will be paused. If you go forward once, the media will play.

Thanks for this workaround :slight_smile:

Inserting videos in Impress slides covered in this article.

Thanks for this comment, but the question actually is not about inserting videos in impress (which works usually pretty well) but to avoid its autoplay as soon as you start the presentation / full screen view. Unluckily, there still is no option like “play on click” or something similar.

Sorry Libreoffice but for embedded videos is the worst part of LOImpress. This bug reported on 2011 and still goes. If you just want to LOImpress for your presentation you can use “Insert Hyperlink” (Ctrl + K). But in this usage you carry your video files with your Impress file. If your click hyperlink video open external video player and you can use pause and play option.