Impress Slideshow Broke in

I updated from 3.5.0 to with no upgrade install problems noted.
Edited a presentation - no problems.
Tried to run the slide show and got lots of problems - blank screen, distorted text, no images.

Tried uninstall and cleaned out leftover program files, registry, etc. Reinstalled clean and had the same problems.

Uninstalled and cleaned again and reinstalled 3.5.0 - now it works.

Looks like a broke in 3.5.1 (Needs a little better regression testing ???)
I saw nothing in the release notes that seems to be in this area.

Any ideas would be appreciated.

This is a bug with hardware acceleration in 3.5.1, if you disable it, the slideshows will work again.

Thanks khagaroth - that “fixed” it! Hope this is a reported bug. It doesn’t hurt on faster machines but I suspect those with slower configurations will see it.

fdo#46901 - SLIDESHOW shows characters too slim with Hardware Acceleration activated - cairo canvas used in error on windows (Status: RESOLVED FIXED, LO 3.5.3)

Was that a pptx file?

Yes, LibreOffice does need more QA people to test for regressions (and bugs in general).

All hands are welcome! See how to contribute at

No, it was not a pptx file - just plain old ordinary odf :slight_smile:

Yes, I have noticed it was seriously broken between 3.5.0 and 3.5.1 and it’s not related at all to the file formats

So, how do you disable hardware acceleration in 3.5.1? No options to do so in any of the menus available (options, settings, etc.). Slide show does not show slides!

Under menu Tools, Options, choose on the left list LibreOffice, View, and on the top right corner Graphics Output un-select “Use hardware acceleration”

Thanks for the directions Pedro.