In LibreOffice Base, the Form Navigation Button Stopped Working

I am halfway through building a LibreOffice Base database. Suddenly the Form Navigation button stopped presenting any information. It had been working up to that point.

I tried starting a new clean database with a test table and the Form Navigation button did not work there either. I did a repair and still no luck. I uninstalled LibreOffice and reinstalled it, but still no response from the Form Navigation button. I am running on an X386-32 bit and using that 32-bit download.

On another computer running X386-64 and LO 5.3.03, the same file operated correctly, with the Form Navigation button bring up the proper form information.

I can’t find anything on the net that relates to this issue.

Your help would be very much appreciated.


Are you sure you are opening your form in EDIT MODE? The FORM DESIGN buttons are only enabled in edit mode.

Hello Mike, i assume that you mean the button inside the Form Design Toolbar, which brings up the Form Navigator.
This button is not part of your database file.
If you right-click on the button and choose “Customize Toolbar…”, there you can add your own (new) button to display the Form Navigator.

  1. click the “Add…” button
  2. in the Category list, select “Controls”
  3. in the Command list, select “Form Navigator”
    then Add.

If that button still doesn’t work, then you could Add a new button and connect it to the following Basic macro:

Sub OpenFormNavigator()
	Dim oFrame, oDispatchHelper, oTmp
	oFrame = ThisComponent.CurrentController.Frame
	oDispatchHelper = createUnoService( "" )
	oTmp = oDispatchHelper.ExecuteDispatch(oFrame, ".uno:ShowFmExplorer", "", 0, Array() )
End Sub

Do you mean from here image description

this dialog: image description

What’s in this box? Is the word “Forms” at the top?